Форма обучения:
дистанционная
Стоимость самостоятельного обучения:
бесплатно
Доступ:
свободный
Документ об окончании:
 
Уровень:
Для всех
Длительность:
4:25:00
Студентов:
5889
Выпускников:
1807
Качество курса:
4.55 | 4.38
Курс предназначен для слушателей, уже имеющих опыт разработки для 1С:Предприятие 8.1. и желающих освоить основы разработки и модификации прикладных решений в системе 1С:Предприятие 8.2.
В курсе на практическом примере рассмотрены основные особенности разработки в режиме управляемого приложения. Помимо описания особенностей работы с такими объектами, как подсистемы, константы, справочники, документы, перечисления, последовательности, нумераторы, регистры накопления, регистры сведений, в курсе уделено внимание организации клиент-серверного взаимодействия. Кроме того, здесь рассматриваются методы конструирования командного интерфейса управляемого приложения и методы работы с управляемыми формами.
 

План занятий

Занятие
Заголовок <<
Дата изучения
Лекция 1
4 минуты
Введение
Введение
Оглавление
    -
    Начало разработки
    Лекция посвящена особенностям начала разработки для 1С:Предприятие 8.2. В частности, здесь можно найти сведения о конвертации баз данных, разработанных для 1С:Предприятие 8.1., об особенностях установки и запуска 1С:Предприятие 8.2., данные об управлении информационными базами. Кроме того, лекция содержит введение в конструирование командного интерфейса, здесь рассматриваются такие объекты, как подсистемы, пользователи и роли.
    Оглавление
      -
      Константы, основы клиент-серверного программирования, общие реквизиты
      Лекция содержит описание работы с константами, обзор и демонстрацию основ клиент-серверного программирования в 1С:Предприятие 8.2, а так же – пример использования общих реквизитов.
      Оглавление
        -
        Справочники, разработка форм
        Лекция посвящена конструированию справочников, вопросам разработки управляемых форм и выполнения различных действий в клиентских методах, в частности, рассмотрена методика вывода сообщений об ошибках в привязке к элементам управления.
        Оглавление
          -
          Справочники
          Лекция посвящена разработке иерархических и подчиненных справочников, реализации дополнительных программных механизмов справочников.
          Оглавление
            -
            Программная работа со справочниками, обработки, простые отчеты
            Лекция посвящена подробностям объектной модели справочников, программной работе со справочниками, а так же – созданию обработок и простых отчетов.
            Оглавление
              -
              Документы, регистры накопления, СКД
              Лекция посвящена разработке документов, работе с регистрами накопления и построению отчетов с использованием системы компоновки данных.
              Оглавление
                -
                Проведение расходного документа, журналы документов, программная работа с документами
                Лекция посвящена конструированию процедуры проведения расходного документа, особое внимание уделено созданию сложных запросов с помощью консоли запросов. Рассмотрена работа с объектом Журнал документов, а так же – методы программной работы с документами.
                Оглавление
                  -
                  Оборотные регистры накопления, последовательности, нумераторы, регистры сведений
                  Лекция посвящена описанию особенностей работы с оборотными регистрами накопления, кроме того, она затрагивает темы использования агрегатов, последовательностей, нумераторов и регистров сведений.
                  Оглавление
                    -
                    1 час 40 минут
                    -
                    Лариса Дятчина
                    Лариса Дятчина

                    Код 

                    &НаКлиенте

                    Процедура ОсновноеКонтактноеЛицоПриИзменении(Элемент)

                    Если НЕ ПроверитьЗаполнениеРеквизита() Тогда

                     Сообщить("Выбранное контактное лицо, "+Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента.");

                    КонецЕсли;

                    КонецПроцедуры

                     

                    &НаСервере

                    Функция ПроверитьЗаполнениеРеквизита()

                     Возврат (Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);  

                    КонецФункции

                    &НаСервере

                    Процедура УстановитьНомерПредставителя()

                     

                     Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения;

                    КонецПроцедуры

                    При проверке выдает ошибку:

                    {Справочник.Контрагенты.Форма.ФормаСписка.Форма(12,11)}: Переменная не определена (Объект)
                     Возврат (<<?>>Объект.ОсновноеКонтактноеЛицо.ПредставительРаботает);   (Проверка: Сервер)
                    {Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,2)}: Переменная не определена (Объект)
                     <<?>>Объект.ТелефонКонтактногоЛица=Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
                    {Справочник.Контрагенты.Форма.ФормаСписка.Форма(17,32)}: Переменная не определена (Объект)
                     Объект.ТелефонКонтактногоЛица=<<?>>Объект.ОсновноеКонтактноеЛицо.КонтактныеСведения; (Проверка: Сервер)
                    {Справочник.Контрагенты.Форма.ФормаСписка.Форма(6,41)}: Переменная не определена (Объект)
                     Сообщить("Выбранное контактное лицо, "+<<?>>Объект.ОсновноеКонтактноеЛицо+",не работает у контрагента."); (Проверка: Тонкий клиент)

                     

                    работаю на версии 1С:Предприятие 8.3 (8.3.10.2650)

                    максим матасов
                    максим матасов
                    Александр Палий
                    Александр Палий
                    Россия, Москва
                    Константин Гераськов
                    Константин Гераськов
                    Россия, Новосибирск